
eClass Grades 6.9.2 User Guide
USING ADVANCE REPORTING FEATURES
Use the eClass Grades advance reporting features to:

� customize your reports

� create report styles

� use foreign languages in your reports

Including Customized Lists

Lists of Students
You can create customized lists containing students from different classes. 
This allows you to generate a single report of students from different classes, 
or report on students in one grading scale from different classes.

You can create as many custom class lists as you want. All the classes in a List 
of Classes must be located in the same directory or folder.

TO CREATE A CUSTOM STUDENT LIST:

1 From the File menu, choose Print.

2 From the �Include in Report Type� popup menu, choose Multi-Class.

3 In the middle section, choose �Customized list of students�, then click 
Create a List.
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4 In the Customize List dialog, highlight a student in the Available Students 
list and click Insert or Append to copy that student to the List of 
Students.

OR

Click Use All to copy all the students from the Available Students to the 
List of Students.

The Available Students list shows all students in the current folder.

5 Click Save As, and specify the name and location for the custom student 
list.

6 Click Save.

TO MODIFY A CUSTOM STUDENT LIST:

1 From the File menu, choose Print.

2 From the �Include in Report Type� popup menu, choose Multi-Class.

3 In the middle section, choose �Customized list of students�, then click 
Edit a List.

4 Locate the custom student list, and click Open.

5 In the Customize List dialog, highlight a student in the List of Students 
and click Remove to remove that student from the List of Students.

OR

Click Remove All to clear all students and recreate the List of Students.

6 Click Save As and specify the name and location for the custom student 
list.
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7 Click Save.

List of Classes
You can create a customized list containing different classes. This allows you 
to work on and report on different classes at the same time.

You can create as many custom class lists as you want. All the classes in a List 
of Classes must be located in the same directory or folder.

Why make a customized list of classes? You might, for example, have two sets 
of classes in a folder that each have a Bob Smith in them, but not the same 
Bob Smith in all of the classes and you don�t want the wrong Bob Smith to 
show up on a report.

TO CREATE A CUSTOM CLASS LIST:

1 From the File menu, choose Print.

2 From the �Include in Report Type� popup menu, choose Multi-Class.

In the bottom section, choose �Customized list of classes�, then click 
Create a List.

3 In the Customize List dialog, highlight a class in the Available Classes 
column and click Insert or Append to copy that class to the List of 
Classes.

OR

Click Use All to copy all classes from the Available Classes to the List of 
Classes.
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The Available Classes column shows all classes in the current folder.

4 Click Save As and specify the name and location for the custom class list.

5 Click Save.

Field Notes

Available Classes This list shows the names of all the Available Classes in the 
current folder.

List of Classes This list shows the Class file names that have been added to the 
List of Classes file.

Append Adds the name highlighted in the Available Classes list to the 
end of the List of Classes list.

Insert Adds the name highlighted in the Available Classes list to the 
List of Classes list, directly above the name that�s highlighted.

Use All Copies all of the classes listed in Available Classes list to the List 
of Classes list, so that the lists are identical.

Remove Removes the highlighted name from the List of Classes list.

Remove All Removes all names from the List of Classes list.

Save As Saves the List of Classes file. Be sure to save your List of Classes 
in the same folder where the classes are located.

Cancel Exits this dialog without saving any changes to the List of 
Classes file.
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TO MODIFY A CUSTOM CLASS LIST:

1 From the File menu, choose Print.

2 From the �Include in Report Type� popup menu, choose Multi-Class.

In the bottom section, choose �Customized list of classes�, then click 
Edit a List.

3 Locate the custom class list, and click Open.

4 In the Customize List dialog, highlight a class in the List of Classes and 
click Remove to remove that student from the List of Classes.

OR

Click Remove All to clear all classes and recreate the List of Classes.

5 Click Save As and specify the name and location for the custom class list.

6 Click Save.

Creating Styles for Reports
Style files are templates that contain settings for reports and for the screen. 
eClass Grades always has one style file open. The name of the currently open 
style file appears at the end of the title bar in each window.

You can create a library of Style files to support your preferences for different 
circumstances.

For example, design a Style file called Gradebook to create a printed 
gradebook when you produce Group Reports, with sufficient space in the left 
margin to allow room for you to punch holes to fit into your gradebook. 
Additionally, include all the data for students, such as name, ID code, 
miscellaneous data, detailed summaries from each category, and the overall 
grade.

Or you can create a Style file called Bulletin for posting Group Reports on 
your classroom bulletin board. This Style file omits the students� names, 
miscellaneous data and category summaries, but include the secret name and 
the final overall grade.

Or design a Style file called Progress that produces Individual Reports you 
can send home to parents. This Style file specifies top and bottom margins of 
0.5 inches, and include the students� names and miscellaneous data but not 
their secret names.

A Style file called Algebra can display scores as decimals, while a Style file 
called Biology displays all scores as whole numbers.
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Several sample Style files were included on your eClass Grades disk. Try these 
Style files with your own Class files. If the reports don�t come out exactly the 
way you want, you can use the Style menu to modify the Style files so that 
reports include only the information you want.

Creating Report Style Files
The Style menu contains many options for reports.

Including Student Data

The Student Data dialog from the Style menu allows you to control what 
student information is included in reports.

By default, the following fields are included:

� Name

� Student Number 

� Miscellaneous 1

� Miscellaneous 2

� Miscellaneous 3

� Signature line

� Citizenship

� Work Habit

� Pass/Fail

Including Assignment Data

In the Assignment Data dialog from the Style menu, you control which 
assignment information is included in reports. By default, the following are 
included:

� Row #

� Description

� Category

� Key to special scores

Setting General Report Preferences

The General Report Prefs dialog from the Style menu allows you to choose 
whether or not certain statistics should be included in reports, how student 
names should appear, margins for reports, and whether zeroes should be 
counted as missing assignments.
Using Advance Reporting Features
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The parts of the General Report Prefs dialog from the Style menu are 
described below:

Setting Individual Report Preferences

Use the Individual Report Prefs dialog from the Style menu to specify the 
information to be included in Individual, Summary, and Multi-Class Reports.

Part of Dialog Notes

Include in Reports Use the checkboxes to include or exclude assignment 
characteristics such as Points Possible, Weights, and 
Adjusted Points Possible. Likewise, a variety of class-wide 
statistics may be included or excluded: Class Average 
(Mean), Maximum & Minimum, Median, and Standard 
Deviation. 

Show Student 
Names

If you select First then Last, each student�s name is 
reversed when printed on reports, so the part of the name 
after the comma is printed first. This depends on your 
having entered student names in the Last, First format in 
the Students window.

Print Reports in You can choose the language of your reports. eClass 
Grades does not translate words and phrases that you type. 
What you type appears in reports as is.
If you use Russian, you need the Cyrillic font.
The language feature only controls certain key-words and 
phrases on reports: the words and phrases that are not 
user-definable through dialogs. For example, in the table of 
scores on a Group Report, the Name column heading 
changes according to the language you select. However, the 
Misc. 1 column heading does not automatically change 
because it is controlled by your settings in the Student Data 
dialog from the Style menu.

Count Zeroes as 
Missing 
Assignments

Controls whether zero scores, including Special Scores with 
a designated value of 0%, are counted the same as missing 
assignments in the following situations: if you select 
Students with ___ or more missing assignments from the 
Report menu�s dialogs, or if you select Missing 
Assignments Only in the Style menu�s Individual Report 
Prefs dialog.

Report Margins The margins you enter here are added to any minimum 
margins that are built into your printer. For example, if 
your printer won�t print any closer than 0.25 inches to the 
left edge of the page and you enter a left margin of 0.5 
inches, then the resulting left margin is 0.75 inches, which is 
suitable for hole-punching reports to put into a binder. A 
right margin of 0 inches means the report will print as close 
to the right edge of the page as the printer allows which is 
usually about 0.25 inches. Likewise, any top or bottom 
margin you specify is added to the 0.5 inches top or bottom 
margin that many printers require.
Using Advance Reporting Features
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Changing Fonts
You can control the appearance of windows and reports using the Font and 
Size commands from the Style menu.

To change the font, select Font from the Style menu and select a font. A 
checkmark appears next to the currently selected font.

To change the font size, select the Size from the Style menu and select a size. 
A checkmark then appears next to the currently selected size.

Opening a Style File
Choose Open Style from the File menu to open an existing eClass Grades 
Style file.

Style files contain your preferences for what information you want included in 
reports, and how that information is presented both onscreen and on reports.

Style file preferences are set up using the Style menu.

Saving Style Files
After you set up a style file, choose Save Style As from the File menu. You can 
then share the report style files with other teachers.

The Save Style As dialog from the File menu saves a Style file with the file 
name and location you specify.

Style files created using the Macintosh version of eClass Grades cannot be 
used by the Windows version, and vice versa. If you need style files for 
Windows users, create them using the Windows version.

Modifying the Content of Reports

Adding a Post Script
You might want to include the same general message at the end of every 
Individual Report, such as a listing of your office hours or an explanation of 
your grading policy.

Two Post Script fields can be used for this purpose.

1 In the Individual Report Prefs dialog from the Style menu, click Post 
Scripts.

2 Type up to 255 characters for each Post Script.

3 Click OK.
Using Advance Reporting Features
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Adding Statistics to Reports
The following statistics can be included on most reports:

� Class Average (Mean)

� Maximum

� Minimum

� Median

� Standard Deviation

The statistics included on reports is determined by selections you make in the 
Style menu�s General Report Prefs dialog.

For class-wide statistics, such as class average, on individual assignments, 
reports show Points, Percentage, or Grade Descriptions, depending on what 
you selected in the Style menu�s Grades dialog.

For example, if you deselect all the checkboxes in the Individual Scores 
column of the Grades dialog, the class statistics for individual assignments 
does not show on reports.

If you select Descriptions in the Grades dialog, then the report shows the 
grade description for all statistics, except for the standard deviation.

Also, because different students can be on different grading scales, the 
statistics are reported as if each student were on grading scale #1.

Even if you select Points in the Grades dialog, Points are not included for 
category, grading period, or overall statistical summaries, since different 
students can have different numbers of points possible.

For example, on Quarter 1 Homework, Johnny could have 300 points 
possible, while a student might have only 260 points possible if s/he received 
some excused scores on homework.

Histograms may also include statistics, depending on what you have selected 
using General Report Prefs from the Style menu.

Also, if you deselect all the checkboxes in the Individual Scores column of the 
Grades dialog, then the class statistics, i.e., average, median, and so on, for 
Assignment Histograms does not show any numbers.

Changing Report Headings
From the Class menu, select Report Headings to enter identifying 
information about the class and teacher.
Using Advance Reporting Features
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Examples of Standard Reports
The following sample reports use the styles shipped with eClass Grades. At 
the top of each illustration, you�ll see the name of the Class file at the left and 
the style file used at the right.

Student List
To print a list of students from the File menu select Open Style and open 
Student List Style in the Samples folder in the eClass Grades folder. Then 
print a Group Report using the Print dialog from the File menu.

If the Samples folder is not in your eClass Grades folder, you can find it on 
your original eClass Grades CD.

If the Stulist Class file is not in your Samples folder, or is not on your original 
eClass Grades disks, you can set up a similar Stulist Style by doing the 
following:

1 Select your preferences in the Student Data dialog.

2 Deselect all the checkboxes in the Grades dialog, except for those in the 
Individual Scores column. This will cause a series of blank underlined 
fields to print next to each students name, so that you can write 
assignments by hand for entering into the computer at a later time.

3 Deselect all other options in the Style menu�s other dialogs, including the 
Individual Report Prefs dialog, the General Report Prefs dialog, and the 
Assignment Data dialog.

4 Choose Save Style As from the File menu and save the new style with a 
name such as Student List Style.

5 After opening or creating a Student List Style, select Group using the 
Print dialog from the File menu to print a list of students.

Field Notes

Class Name Type the class name as you would like it to appear on reports. You can 
type up to 40 characters.
If you leave the Class Name blank, the Class file name is used on reports.

Teacher 
Name

This feature appears only on School or Department site license versions 
of eClass Grades. It allows each authorized teacher to enter his/her own 
name to appear on reports along with the department or school name.
Teacher names are limited to 40 characters. In this field, type one or 
more names as you would like them to appear in the Prepared by section 
on reports.
The department or school name is encoded into the program. 
Information typed in this dialog is stored in the Class file, so you will 
need to enter the teacher and class name for each class. In earlier versions 
of eClass Grades, this field appeared in the General Report Prefs dialog.
Using Advance Reporting Features
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6 To print a blank assignment grid beside your student list, choose a range 
of assignments that starts with the number of the first assignment you 
have not yet entered. Since the range will cover assignments that do not 
yet exist in your Class file, eClass Grades will print the student list with 
blank assignment fields, which is useful for filling in assignments by hand 
so you can enter them into eClass Grades later.

Assignment List
If you want to print a list of your Class file assignments, do the following:

1 Open your Class file.

2 Open the Style file called Assignment List Style in eClass Grades�s 
Samples folder.

3 From the File menu, choose Print, then select Individual from the 
dropdown menu.

4 Change the assignment range so that all your assignments will be 
included.

5 Change the student range to Students # 1 through 1 so that only one copy 
of the assignment list will print.

6 Click Preview or Print.

Individual Report � Simple
In this Simple Individual report, all assignments are based on points only, 
without weights.

TO PRINT A SAMPLE SIMPLE INDIVIDUAL REPORT:

1 From the File menu, select Open Style.

2 Select the Brief style file, and click Open.

3 From the File menu, choose Print, then select Individual from the 
dropdown menu.

4 Click Print.

Short Class A Simple Individual Report Brief Style

Meg O. Watt 11/28/97   Biology II
Prepared by Ms. Kari O. Key, Singalong School  

Points Points
Assignment Score Possible Assignment Score Possible
Homework 1    7.0 10 Lab 1    48.0 50
Homework 2    9.0 10 Test 1    92.0 100

Overall Grade:  156.0/170.0 91.8% A-

11/28/02
Using Advance Reporting Features
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Tips and Notes

If you print this report with sufficiently narrow columns, you�ll notice that the 
assignment table is broken into two or more parts to save paper.

If you want to avoid multiple tables, widen the assignment description column 
by dragging the heading separators in the Assignments window.

If you don�t want to show any information about categories, from the Class 
menu, select Categories, and deselect the �Include Grade Summary In 
Reports� checkboxes for all the categories.

If you don�t want to show any information about grading periods and overall 
summaries, from the Class menu, select Grading Periods and Overall 
Summaries and deselect the Grade Summary checkbox in the Include In 
Reports section of both dialogs.

To delete non-essential items such as the Miscellaneous field and Assignment 
Number column, use Assignment Data from the Style menu.

To fit several of these short reports on each page, choose Individual Report 
Prefs from the Style menu, and deselect �One Report Per Page�. Use the 
same dialog to specify the Report Title for Individual Reports.

To change the date format, type the date in the format you want in the 
Individual dropdown in the Print dialog from the File menu.

If you have a site or department license, you can change the teacher name in 
the Report Heading dialog from the Class menu.

You can use the Style menu to control the Font and the Size of text as it 
appears in each section of the report.

Individual Report � Detailed
The Detailed Individual Report shows all of the sections that may be included 
in Individual Reports.

TO PRINT A SAMPLE DETAILED INDIVIDUAL REPORT:

1 From the File menu, select Open Style.

2 Select the Full Style file, and click Open.

3 From the File menu, choose Print, then select Individual from the 
dropdown menu.

4 Click Print.
Using Advance Reporting Features
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Orchestra Class A Detailed Individual Report Full Style

Tips and Notes

Using the Class menu, you can design your own Special Scores, for example, 
+ for Outstanding, OK for Completed, and so on. The special score shown as 
ex means Excused, so this assignment does not affect this student�s grade.

The section below the assignment table displays the grade summaries for each 
grading period, for example, First Quarter and Second Quarter.

Each grading period can contain its own set of categories, for example, 
Recitals, Homework, and Tests.

An overall summary is also shown.

Progress Report for Gogh, Les December 15, 1997   Orchestra
Prepared by Ms. Kari O. Key, Singalong School
ID: Zoom   After School: Chess  Phone/Instrument: 555-2345/Violin  

Class Points
Assignment Date Category Score Median Possible Weight

Notation homework 11/3 Tests    17.0 = 85.0% B    17.0 20   1.000
Recital 11/10 Recitals OK    31.0 37   2.703
Notation quiz 11/15 Tests ex     8.0 10   1.000
Final Exam 11/20 Tests    92.0 = 92.0% A    85.0 100   1.000

Key: OK=Completed   ex=Excused   

First Quarter:  89.0% B+
Recitals (60.0% of grade): 89.0% B+
Homework (40.0% of grade): 88.9% B+

Second Quarter:  83.0% B
Recitals (50.0% of grade): 75.1% C
Tests (50.0% of grade): 90.8% A-

Overall Grade:  86.0% B

Second Quarter Attendance:  
2 Excused, 1 Tardy
Excused: 11/15 11/22 
Tardy: 11/20 

Entered class 2 weeks into the year, but did a good job of catching up.
Les has great potential. He should study more for his tests. Improved effort on assignments. 
Final exam grade was 92.0 out of 100 points possible, which equals 92.0%, for a grade of A.
This score ranks Les 2 out of a class of 10.
 

Student Parent/Guardian Date

Please call me at 555-1234 between 3:00 and 4:00 p.m. if you have any questions. 
Reminder: Fall concert is this Thursday, 7 p.m.

June 14, 2002
Using Advance Reporting Features
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The line starting with the words Entered class 2 weeks... is an example of a 
Student Note. Following the student note are several comments, which are 
designed using the Comments dialog.

When you�re designing comments, you can use Space instead of Enter after 
each comment text. This links comments together into a paragraph. Notice 
the use of comment variables to merge students� names, scores, and so on, 
into the comments. Assign comments to students in the Students window.

The third line of the report is optional, depending on what is selected in the 
Student Data dialog from the Style menu. The Student Data dialog also 
controls the Miscellaneous column titles which are shown here as After 
School and Phone/Instrument.

The next section is the assignment table. The Assignment Data and General 
Report Prefs dialogs control which columns are included in this table.

The Grades dialog controls whether each score is expressed as a Grade 
Description, a Percentage, or a Point value. All three are shown here.

In the Assignments window, the Recital assignment has been given 37 points 
possible and 100 adjusted points, resulting in a weight of 2.703 (100 ÷ 37).

The points possible, adjusted points, and weight values appear in the report 
when you select checkboxes in the General Report Prefs dialog.

Underneath the assignment table is the key to special scores included by a 
checkbox in the Assignment Data dialog.

After the key to special scores, the grading period, category, and overall 
summaries are printed.

The format of these grades, whether expressed as a Grade Description, a 
Percentage, or a Point value, is determined by settings in the Grades dialog.

Near the bottom of the report, a signature line has been included by selecting 
a checkbox in the Student Data dialog.

In the Individual Report Prefs dialog from the Style menu, you can enter text 
for the post scripts, which appear last on the report.

Letter-Style Report Using Comments
The Letter-Style Report produces a personalized letter using comments and 
smart variables.

TO PRINT A SAMPLE LETTER-STYLE REPORT:

1 From the File menu, select Open Style.

2 Select the Letter Style file, and click Open.

3 From the File menu choose Print and then Individual.
Using Advance Reporting Features
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4 Click Print.

Letter Class A Letter-Style Report Using Comments Letter Style

Tips and Notes

Create comments by choosing Comments from the Class menu. They may be 
simple, one-line, generic remarks, or anything else you may want to include, 
provided the length does not exceed 250 characters. They can contain 
comment variables from a popup menu in the Comments dialog.

The Letter-Style report shown uses comment variables to stand for a student�s 
first name, such as Polly for this student whose last name is Graf. Similar 
comment variables are available for grades, in particular categories such as 
Math, or for the overall combined grade. Smart pronouns, such as his/her, 
he/she, and so on, are comment variables that depend on whether you enter 
M or F for in the M/F column of the Students window.

Class Work Summary for Polly Graf 11/27/97   Room 12
Prepared by Ms. Kari O. Key, Singalong School 

Dear Parents of Polly Graf:

Polly has great potential.  On her science test, she received 46 out 
of 50, for a grade of 92.0% (A).  Her behavior has been 
improving, but she still sometimes talks at inappropriate times.  

Here is a summary of Polly's grades in all subjects:
In Math, Polly's current grade is 90.0% A.
Her Science grade is 80.0% B.
In Reading, her grade is 90.0% A.
    (very creative book report!)
Her Social Studies grade is 95.0% A.

Please sign and return this report to me.  Thank you.

Student Parent/Guardian Date

P.S. I look forward to meeting you at Open House, this Thursday 
at 7:30 p.m. in Room 12.

6/27/02
Using Advance Reporting Features
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You can also use comment variables to represent a student�s academic rank 
and the class size.

If you want the comments you define to appear on a separate line, press Enter 
at the end of the comment�s definition. You can link comments together to 
form paragraphs by pressing Space instead of Enter. After you design your 
comments, note the numbers of those core comments that you want to 
appear on all students� reports.

In this example, that would be all comments starting with Dear Parents of... 
and ending with Ms. Key; except for the numbers of personalized comments 
which are only used for certain students, for example, �very creative book 
report!�. Enter these in the order you want them to appear in your letter.

Then, in the Comments column of the Assignments window, enter the 
numbers of the core comments, separated by commas.

Finally, type the comment numbers for any personalized comments for 
certain students, to add a truly personal touch to the reports.

This report was designed as an Individual report, but the assignment table was 
omitted by deselecting �Assignment Table� in the Individual Report Prefs 
dialog from the Style menu.

The grade summaries were omitted by selecting Grades from the Style menu, 
and deselecting all the checkboxes in the top half of the dialog.

Also from the Style menu, the Individual Report Prefs dialog provides for: a 
Report Title, such as Class Work Summary, for a sufficient number of 
Reserved __ Lines in the Comments and Notes field and up to two Post 
Scripts to appear at the end of all students� reports.

Gradebook Group Report
The Group Report prints reports that look like a gradebook.

TO PRINT A SAMPLE GRADEBOOK GROUP REPORT:

1 Open your Class file. Then open the Gradebook Style file.

2 Choose Group using the Print dialog from the File menu, then click Print.
Using Advance Reporting Features
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Medium Class A Gradebook Group Report (page 1) Gradebook Style

A Gradebook Group Report (page 2)

Tips and Notes

General Report Prefs from the Style menu lets you specify a left margin to 
allow room for hole-punching to fit a binder, and lets you choose whether to 
include points possible, weights, adjusted points possible, class average, and so 
on.

Use the Grades dialog to select which grade summaries to include. Here, 
summaries are included for categories and for the overall summaries.

Biology II  September 12, 1997
 Prepared by Ms. Kari O. Key, Singalong School

#  Assignment  Misc.  Category
1 Homework 1 p.12 #5,7,11,1 Homework
2 Homework 2 p.17 #2,12,15 Homework
3 Lab 1 10/15/97 Labs
4 Test 1 10/20/97 Tests

# Name ID Phone Scores
   1 2 3 4

1 Graf, Polly Truth 555-7654    10 dr    47   100
2 Hand, Boyd N. 2nBush 555-1234     9     9    48    98
3 Gee, Al R. Achoo 555-9876     8     8    40    97
4 Burns, Mai Tung Pepper 555-2345     7     7    50    94
5 Hyde, Tanya Beach 555-8765     6     8    48    95
6 Plain, Yolanda Pilot 555-3456     5     9    50    80
7 Poole, Gene DNA 555-4567     6    10    49    56

Pts Possible 10 10 50 100
Weight 1.000 3.000 1.000 1.000

Key: ab=Absent   ch=Cheating   OK=Completed   dr=Dropped Score   ex=Excused  
 (blank)=Incomplete    +=Outstanding   tr=Truant   -=Unacceptable   

June 12, 2002

# Name Quarter 1 Quarter 1 Quarter 1 Quarter 1 Overall
 Tests Homework Labs Grade Grade

1 Graf, Polly 100.0% 100.0% 94.0% 98.8% 98.8% A
2 Hand, Boyd N. 98.0% 90.0% 96.0% 95.2% 95.2% A
3 Gee, Al R. 97.0% 80.0% 80.0% 88.5% 88.5% B+
4 Burns, Mai Tung 94.0% 70.0% 100.0% 88.0% 88.0% B+
5 Hyde, Tanya 95.0% 75.0% 96.0% 89.2% 89.2% Pass
6 Plain, Yolanda 80.0% 80.0% 100.0% 84.0% 84.0% B
7 Poole, Gene 56.0% 90.0% 98.0% 74.6% 74.6% C

Key: ab=Absent   ch=Cheating   OK=Completed   dr=Dropped Score   ex=Excused   (blank)=Incomplete   
+=Outstanding   tr=Truant   -=Unacceptable   
Using Advance Reporting Features
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The report will continue horizontally over several pages to fit as many 
assignments and grade summaries as you need.

If you have a large number of students, the report will continue vertically over 
multiple pages.

When you select Group using the Print dialog from the File menu, you may 
extend the range of assignments as far as you need. This lets you print blank 
grids to record scores by hand before you have a chance to enter them into 
the computer.

The assignment table at the top of each page provides room for you to write 
new assignments.

Below the assignment table, blank lines are printed as needed to make the 
student names line up across all pages.

You can also extend the range of students to make room for new arrivals.

Roll Book Report
Roll Book reports print blank roll sheets.

TO PRINT A SAMPLE ROLL BOOK REPORT:

1 From the File menu, choose Open Style.

2 Select the Gradebook Style file, then click Open.

3 From the File menu, choose Print, then select Roll Book. Click Print.

Orchestra Class A Roll Book Report Gradebook Style

Roll Book for Orchestra
Prepared by Ms. Kari O. Key, Singalong School  

Mo Tu We Th Fr Mo Tu We Th Fr Mo Tu We Th Fr 
1 Claire, I. D.
2 Day, Holly
3 Gee, Al R.
4 Gogh, Les
5 Graf, Polly
6 Pend, Pat
7 Rhoades, Dusty
8 Sudden, Oliver
9 Vail, Noah

10 Wave, Mike R.
Using Advance Reporting Features
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Tips and Notes

eClass Grades�s Roll Book reports give you a simple, blank grid.

Photocopy them to replace your traditional roll book.

The students� names are printed at the left, and the days of the week are 
printed at the top of each column of the grid, with enough room for you to 
write in the dates.

From the Style menu, you can use the Margins settings in the General Report 
Prefs dialog to provide enough margin to allow for hole punching.

Bulletin Board Group Report
This Group Report works well for posting grades confidentially on a bulletin 
board in your classroom.

TO PRINT A SAMPLE BULLETIN BOARD GROUP REPORT:

1 Open your Class file and the Bulletin Board Style file.

2 From the File menu, choose Print, then select Group. Click Print.

Short Class A Bulletin Board Group Report Bulletin Board Style

Biology II  September 12, 1997
 Prepared by Ms. Kari O. Key

#  Assignment  Misc.
1 Homework 1 p.12 #5,7,11,1
2 Homework 2 p.17 #2,12,15,27,33
3 Lab 1 10/15/97
4 Test 1 10/20/97

ID Scores Overall
 1 2 3 4 Grade
2nBush     9     9    48    98 96.5% A
Achoo     8     8    40    97 90.0% A-
Beach     6     8    48    95 92.4% Pass
Cautious dr dr dr    76 76.0% C
DNA     6    10    49    56 71.2% C-
Pepper     7     7    50    94 92.9% A
Pilot     5     9    50    80 84.7% B
Power     7     9    48    92 91.8% A-
Quit     8     9    47    58 71.8% C-
Truth    10 dr    47   100 98.1% A
Class Average     7     9    47    85 86.5% B
Pts Possible 10 10 50 100

Key: ab=Absent   ch=Cheating   OK=Completed   dr=Dropped Score   
ex=Excused   (blank)=Incomplete   +=Outstanding   tr=Truant   -=Unacceptable   

June 15, 2002
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Tips and Notes

From the Style menu, use the Student Data dialog to omit the names row 
numbers, and miscellaneous student data fields.

Use the Assignment Data dialog to include the row number for reference, and 
to include any miscellaneous assignment information.

Use the General Report Prefs dialog to include any class statistics and 
assignment information, such as class average, median, possible points, and 
assignment weights.

Use the Grades dialog to include grade summaries.

In this example, all checkboxes have been deselected under Category 
Summaries and Grading Period Summaries leaving only the Overall 
Summaries and Individual Scores.

If you use General Report Prefs to set the right margin to 3.0 inches, there will 
not be room to display two assignment tables side-by-side on this report, so 
only one assignment table will be printed.

Before you print a report for your bulletin board, save your Class file. Then 
use the Utilities menu to Sort Students by Student Number. This makes it 
easier for students to locate their row on the report, and prevents students 
from guessing where their friends are by their position in the list.

When you�re finished printing, select Revert Class from the File menu to re-
open the unsorted Class file.

Overall Summary Progress Graph
Choose Overall Summary to generate a graph of a student�s progress 
throughout the entire year, or select Grading Period or Category to limit the 
graph to a particular grading period or category.

TO PRINT A SAMPLE OVERALL SUMMARY PROGRESS GRAPH:

1 From the File menu, select Open Style.

2 Select the Default Style file. Then click Open.

3 From the Utilities menu, select Progress Graphs.

4 Click Print.
Using Advance Reporting Features
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Sample Class An Overall Progress Graph Default Style

Tips and Notes

In this example, Show Averages has been selected to include the class 
averages for each assignment shown as small squares.

Many other options are available, such as bundling groups of assignments 
together, showing cumulative data points, or using standardized z-scores.

Elementary Report Using Subject Categories
This is one of the two main approaches used by Elementary teachers to show 
many subjects on a single report.

All subjects are stored in a single Class file. The other approach, Multi-Class 
Reports, uses one Class file for each subject, and offers the advantage of 
allowing categories within each subject.

Progress Graph for Poole, Gene
Biology II   September 12, 1997

Prepared by Ms. Kari O. Key
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June 12, 2002
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An Elementary Report
Categories As Subjects Class Using Categories As Subjects Categories As Subjects Style

TO PRINT A SIMILAR REPORT:

1 From the File menu, select Open Style.

2 Select the �Category as Subjects� Style file. Then click Open.

3 In the Print dialog from the File menu, select Individual and click Print.

Polly Graf De ce mbe r 1 5 , 1 9 9 7    Room 1 2
Prepared by Ms. Kari O. Key

# Assignme nt Cate gory Score
1 Addition Worksheet Math Excellent
2 Africa Map History Good
3 Sideways Stories Reading Excellent
4 Subtraction Work Math Excellent
5 Science Test #1 Science Excellent
6 Book Report Reading Excellent
7 Current Events Test History Excellent
8 Division Quiz Math Excellent
9 Animal Behavior Science Good

1 st S ix We e ks:
Math 100.0% Excellent
Science 92.0% Excellent
Reading 94.0% Excellent
History 85.0% Good

2 nd S ix We e ks:
Math 90.0% Excellent
Science 80.0% Good
Reading 90.0% Excellent
History 95.0% Excellent

1 st S ix We e ks Atte ndance :
2 Excused, 1 Tardy, 0 Unexcused, 0 Truant

2 nd S ix We e ks Atte ndance :
0 Excused, 1 Tardy, 0 Unexcused, 0 Truant

Good job on assignments. She should study more for her tests. Improved effort on
assignments. Polly has great potential.

June 15, 2002
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Tips and Notes

In this report, eClass Grades� categories are being used to keep track of 
subject areas, all in a single Class file. This is the approach used by many 
Elementary school teachers. Each Individual Report can display a summary of 
grades per grading period in up to 10 subject areas, such as Math, Science, 
Reading, and History. Choose Categories from the Class menu, and enter your 
subject areas.

You can also use this method to display up to 20 grading periods.

Most elementary teachers who use categories for subjects will want to select 
Grades from the Style menu, and deselect the three boxes under Overall 
Summaries, since an overall grade across all subjects is not usually of interest. 
In this example, the only selected checkbox under Individual Scores is Grade 
Description, so the scores show up as Good, Excellent, and so on, instead of 
numbers.

If you use General Report Prefs to set the right margin to 3.0 inches, there will 
not be room to display two assignment tables side-by-side on this report, so 
only one assignment table will be printed.

Multi-Class Elementary Report
The Multi-Class Elementary Report is one of the two main approaches used 
by Elementary teachers to show many subjects on a single report.

This approach depends on keeping each subject in a separate Class file, and 
offers the advantage of allowing categories within each subject. The other 
approach, Using Categories for Subjects, offers the advantage of simplicity, 
since all subjects are stored in a single Class file.
Using Advance Reporting Features
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Art Class and so on. A Multi-Class Elementary Report Multi-Class Style

TO PRINT A SIMILAR REPORT:

1 Open one of the Class files that contains all of your students.

2 Open the Multi-Class Style file in the Elem folder in the eClass Grades 
Samples folder.

3 Choose Multi-Class using the Print dialog from the File menu.

4 Select All classes to include all classes in the current directory, and select 
All students to generate reports for all students in the currently open 
Class file.

Progress Report for Graf, Polly December 15, 1997
Prepared by Ms. Kari O. Key  
ID: Truth   Misc. 1: Soccer  Misc. 2: 555-7654  

Art

Grades Quarter 1 Quarter 2 Quarter 3 Quarter 4 Overall
Tests A+ A A+ A A
Homework A+ A A+ A A
Projects A C A C B
Combined A A- A A- 94.7% A

Math

Grades Quarter 1 Quarter 2 Quarter 3 Quarter 4 Overall
Tests A- A A+ A A
Homework D- A A+ A B
Labs B- C A C B-
Combined C+ A- A A- 89.7% B+

Social Studies

Grades Quarter 1 Quarter 2 Quarter 3 Quarter 4 Overall
Tests A+ A B- A A
Homework A+ A F A B
Research A C C- C C+
Combined A A- D A- 86.5% B

Attendance Quarter 1 Quarter 2
Excused 1 0
Tardy 1 0
Unexcused 0 0
Days Enrolled 54 31

Polly's reputation for honesty is impeccable.
Polly has great potential. She should study more for her tests. Improved effort on assignments. 

Student Parent/Guardian Date

June 15, 2002
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Tips and Notes

Use options in this dialog to customize lists of classes or lists of students to 
include in the reports.

This report combines grade summaries from several different Class files.

To make each student�s comments appear at the end of each report, the Class 
file Social Study Class has been used to assign comments to students, since 
Social Studies is the last subject to appear on the report.

The Categories dialog from the Class menu has been used to design a set of 
weighted categories for assignments in each subject or class.

In the Class Name dialog is a place to type the name to appear at the 
beginning of each subject�s section on the report, for example, Social Studies 
in Social Study Class.

In the Individual Report Prefs dialog from the Style menu, �Use Tables for 
Summaries� has been selected to produce the grade summary tables on the 
report.

Comments and Notes have been selected in Social Studies only.

The Grades menu dialog shows only Grade Description selected under 
Grading Period Summaries. This controls the format of grades in the table 
columns labeled Quarter 1, Quarter 2, and so on.

Under Overall Summaries, both Grade Description and Percentage have been 
selected, as shown in the OVERALL table columns.

The checkboxes under Category Summaries are ignored whenever tables are 
used for summaries.

Assignment Histogram
Histograms show class-wide performance on individual assignments or 
groups of assignments.

TO PRINT A SIMILAR REPORT:

1 From the File menu, choose Open Style.

2 Select the Default Style file. Then click Open.

3 Choose Histograms from the Utilities menu.

4 Select Percentage, Grade Descrip., or Points.

5 Click Print.
Using Advance Reporting Features
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Sample Class An Assignment Histogram (Bar Graph) Default Style

Tips and Notes

In the General Report Prefs from the Style menu, all possible class statistics 
have been selected, such as Class Average, Maximum & Minimum, Median, 
and Standard Deviation.

By default, the Number of Bars is set to Low, but you can select Medium or 
High option.

Troubleshooting

Formatting and Printing Issues
Many formatting and printing issues are specific to the printer you are using. 
Check the printer guide for information on how to best use the printer and 
avoid problems with the printout.

Report Doesn’t Print

If your report doesn�t print, select Chooser from the  menu, and verify 
that the correct printer is selected. Also, within eClass Grades, choose Page 
Setup from the File menu, and click OK to update the printer settings. If you 
still have trouble printing, then you might want to contact Apple technical 
support or your printer manufacturer for assistance with setting up your 
printer.

Statistics for Final Exam (200 Points)
Biology II   September 12, 1997

Prepared by Ms. Kari O. Key

Average:   173.5
Maximum:   198.0
Minimum:   150.0
Median:   173.0
Std. Deviation:    16.2
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Part of a Report Chopped off

If part of a report is �chopped off,� try changing the report margins or page 
orientation. Choose General Report Prefs from the Style menu to change 
margins, or Page Setup from the File menu to choose landscape paper 
orientation. Also check your printer manual for instructions on printing closer 
to the edge.

Two Page Group Report Leaves Lots of Wasted Space

From the Style menu, choose Student Data to eliminate any unnecessary 
columns from reports, and choose General Report Prefs from the Style menu 
to change your margins. You may also need to reduce the column width on 
your reports.

In addition, try reducing the font size, but we recommend that you avoid 
going below font size 8.

Each Individual Report Takes Up a Whole Page Wasting Space

In the Individual Report Prefs dialog from the Style menu, deselect �One 
Report Per Page�, and adjust the Lines for Comments and Notes field down.

Comments on Reports are Too Close Together

When you design each comment, make sure that you press either Space or 
Enter after the text of the comment.

Long Lines Running Off the Right Edge of the Page on Individual Reports

From the Style menu, choose General Report Prefs and omit some of the 
statistics from reports.

To decrease the width of columns, use a smaller font size. In Print Setup, 
choose landscape paper orientation. In the Style menu, deselect columns you 
don�t need to include in your report.

Gap Between Assignment Descriptions and Main Table of Scores

The gap is intended to make the first student names line up on all pages of a 
long Group Report.

On any Group Report, the student list should begin the same distance from 
the top of the page, making it easier to follow a student across several pages.

If almost all students fit on one page, try choosing a smaller font from the 
Style menu.

Style Menu Changes Are Lost After Quitting and Re-Opening eClass Grades

From the File menu, choose Save Style As to save your Style preferences. 
Make sure you are using the correct Style file.
Using Advance Reporting Features
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On a Dot Matrix Printer, Reports Begin Mid-Page

1 Before you print, turn the printer off.

2 Roll the printer carriage so that the paper perforation is lined up with the 
print head.

3 Turn the printer on.

4 Print the report again.

Pressing Cancel Doesn't Always Stop Printing

Most printers have built-in memory that stores a substantial amount of 
information before it actually prints, so the printer may continue printing for a 
while after you stop sending it information.

You can always turn the printer off. Some printers note if the power goes off 
and will resend the job once the power is turned back on. Additionally, 
shutting the printer may cause a paper jam with some laser printers. Some 
printers have a reset switch that lets you clear out the stored text. Consult your 
printer documentation.

During printing, eClass Grades checks frequently for Cancel being pressed; 
but keep in mind that sometimes there is a delay before Cancel is noticed. So 
be persistent.

Content Issues

Print Individual Reports for Some But Not All Students

Before you print reports, select the rows in the Students window.

When you print a report, select �Only highlighted students in the Students 
window� in the Print dialog.

Report Shows All Assignments Not Just Those in the Most Recent Grading Period

For most choices from the Print dialog, the dialog gives you the opportunity 
to change the lowest assignment number to 1.

To report assignments in the most recent grading period, enter the lowest 
assignment number for that grading period.

Percentages on Reports Don't Agree with Calculations

If eClass Grades gives a student a percentage that does not equal his/her 
points achieved divided by points possible when done on a calculator (or even 
by hand), this does not necessarily mean that eClass Grades is malfunctioning.

First, check the Scores window to make sure that you entered all scores 
correctly. Then, check the Assignments window to be sure that all 
assignments have the correct number of points possible and the correct 
Using Advance Reporting Features
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weights. Make sure you�ve entered the correct category next to each 
assignment.

If you�re not using multiple categories, then the category numbers should all 
be the same � with category #1 called Total Points.

Use Categories from the Class menu to make sure that you have entered all 
assignment categories correctly and that all the category weights are filled in.

If you have divided the file into more than one grading period, check the 
Grading Periods dialog from the Class menu to make sure you have weighted 
the grading periods correctly.

Check to make sure you have correctly specified Use Category Weights, 
Ignore Category Weights, or Weigh Categories Equally for each grading 
period.

Check the Overall Summaries dialog from the Class menu to make sure 
you�ve selected Ignore Grading Period Weights if you don�t want to weight 
your grading periods.

Printed Report Does Not Conform to Grades Settings

The settings in the Grades dialog generally control how each grade will appear 
on reports: as a grade description, points, or percentage.

Normally, you can control these settings completely for individual assignment 
scores, category summaries, grading period summaries, and overall 
summaries.

However, there is one instance where eClass Grades may override these 
settings. If �Use Tables for Summaries� is selected in the Individual Report 
Prefs dialog, then the Grading Period Summaries checkboxes control how 
both the grading period summaries and category summaries print, and the 
Category Summaries checkboxes are ignored. This is necessary for the correct 
formatting of reports.

In addition, the Overall Summaries checkboxes control how the Overall 
Grade across grading periods and the overall category grade appear on 
reports.

Prevent Name from Printing on Reports

If a teacher wants to include a student in a class who will not be doing any of 
the class assignments, place the �~� (tilde) symbol in front of the student�s 
name to keep his/her grade from printing on reports.

Additionally, names with tildes in front of them are placed at the end of the 
student list if you sort the list alphabetically.
Using Advance Reporting Features
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Grade Column of the Scores Window Doesn't Agree with Grade Summaries on Reports

Check if you are using Alternate Grades, and check the following to make 
sure you have selected the correct categories, grading periods, and overall 
summaries:

� Screen Prefs from the Style menu to make sure you have selected the 
correct Grade to Display.

� Grades from the Style menu.

� Categories from the Class menu.

� Grading Periods from the Class menu.

� Overall Summaries from the Class menu.

Incorrect Comments on Individual Reports

First, design your comments using Comments from the Class menu. Each 
comment appears next to a comment number.

In the Comments column of the Students window, type a string of comment 
numbers separated by commas, not the comments themselves.

Also, check the Individual Report Prefs dialog from the Style menu to make 
sure that �Comments and Notes� is selected, and that you have reserved a 
sufficient number of lines for comments.

Overall Summaries or Category Grades Don't Appear on Reports

From the Class menu, look at the Grading Periods and Categories dialogs.

Make sure you have selected the appropriate boxes to include the grade 
summary for each grading period and category.

In the Overall Summaries dialog in the �Include In Reports� section, make 
sure one or both �Overall Category Grades� and �Grade Summary� is 
selected.

Also go to the Grades dialog from the Style menu and make sure that at least 
one checkbox is selected in the Overall Summaries column.

Merge Class Files in the Same Subject for Combined Histogram or Group Report

If the assignment lists of all classes are identical, you can build one large Class 
file from them.

1 From the Windows menu, choose Students.

2 From the Edit menu, choose Select All.

3 From the Edit menu, choose Copy.

4 Open another class that has the same assignment list.
Using Advance Reporting Features
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5 Use Save Class As to create a copy of it with a different file name.

6 Move to just below the last student in the Students window and, from the 
File menu, choose Paste.

7 Save the Class file.

Repeat the above procedure of pasting students into new classes as many 
times as you want.

Another Teacher's Name Appears on Reports

If you are sharing eClass Grades on the same computer with another teacher, 
or if you are using eClass Grades over a network, be sure to open your Style 
file after you open your Class file. If you don�t open your Style file, the name 
of the teacher who used the computer before you will appear on the report. 
Use a unique style name to avoid confusion.

The encoded name of the teacher who has purchased eClass Grades will 
always appear on reports. Thus sharing someone else�s copy of eClass Grades 
will not allow you to print reports with your name on them. On a network 
using a department or site license, you can type your name under the Report 
Heading dialog from the Class menu. Make sure that you have not mistakenly 
opened another teacher�s grade book or files.

Include or Omit Averages, Median, and Standard Deviation

Use the checkboxes in General Report Prefs from the Style menu to include 
or omit statistics from reports.

Some But Not All Students and/or Assignments Show Up on Reports

Make sure the correct Assignment or Student range is selected in the Print 
dialog before printing.

Also check the Individual Report Prefs dialog located in the Style menu to 
make sure you have not selected Missing Assignments Only.

Data Has Disappeared from Reports

Select choices in the Style menu, especially Grades, General Report Prefs, and 
Student Data.

After a Score is entered in the Scores window, the Score changes to verify 
you�ve selected the correct information.

Working in Foreign Languages
You can use foreign languages in your reports. You can print reports using 
different languages for different students, such as Spanish students getting 
Spanish reports and other students getting their reports in English.
Using Advance Reporting Features
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Print Class Reports in Two Languages
If you want to produce reports in another language, you may want to use 
different languages for different students.

To tell eClass Grades which font to use when printing different sections of 
the report, use the Fonts dialog from the Style menu.

TO CREATE SPANISH REPORTS FOR SOME STUDENTS AND ENGLISH REPORTS FOR 
OTHER STUDENTS IN THE SAME CLASS:

1 Open the Style file you use for English-language reports so that you can 
modify it for Spanish.

2 Choose Individual Report Prefs from the Style menu and change the Title 
of the report to its Spanish equivalent.

3 In General Report Prefs from the Style menu, select Spanish from the 
�Print Reports in� popup menu.

4 If you have a department or school site license, change the Teacher Name 
to the Spanish equivalent, for example, from Mr. Smith to Señor Smith.

5 From the Style menu, open the Student Data and Assignment Data 
dialogs to change the Misc. Column Titles to their Spanish equivalents.

6 Then, select Save Style As from the File menu and save the Style file with 
the name Spanish Style file.

7 Open the Class file that contains both English and Spanish speaking 
students.

8 Use Save Class As from the File menu to create a Class file with an 
appropriate new file name, for example, Period 2 Spanish.

9 In the Students window, remove the English-speaking students from the 
list by clicking the row numbers to the left of their names and using Cut 
from the Edit menu.

10 Go through all of the menu choices in the Class menu and translate all the 
English text into Spanish. This includes the descriptions of all categories 
and grading periods.

11 Rewrite all your Comments and Special Scores in Spanish.

12 In the Assignments window, translate all the assignment descriptions into 
Spanish.

13 Save this Spanish Class file, then re-open the original English Class file.

14 In the Students window, cut all the Spanish-speaking students and save 
the Class file.

Now you have two Class files for your class: one in Spanish that contains 
the Spanish-speaking students and one in English that contains the 
Using Advance Reporting Features
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English-speaking students.

TO CREATE ASSIGNMENTS AND PRINT REPORTS IN BOTH ENGLISH AND SPANISH:

1 When you give new assignments, add them to your English Class file, 
enter the scores, and save.

2 Then open the Spanish Class file, type the assignment names in Spanish, 
enter the scores, and save.

3 If you want to print English reports, open the English Class file and the 
English Style file.

OR

If you want to print Spanish reports, open the Spanish Class file and the 
Spanish Style file.

When you have the correct Class file and Style file open, you are ready to 
print your reports.

Later, you can recombine the Spanish and English groups into a single 
class for printing histograms or reports, as long as both groups have the 
same assignment list, in the same order, with the same number of points 
possible on each assignment.

TO COMBINE THE SPANISH AND ENGLISH GROUPS INTO A SINGLE CLASS:

1 Open the Spanish Class file and open the Students window.

2 From the Edit menu, choose Select All.

3 From the Edit menu, choose Copy.

4 Open the English Class file and open the Students window.

5 Move the cursor to the last student and press Return. This creates a 
student at the end of the list.

6 From the Edit menu, choose Paste to paste the Spanish-speaking 
students, along with their scores, into this Class file.

7 To sort students alphabetically, choose Sort Students from the Utilities 
menu, and click Sort. Then from the File menu, choose Save Class As to 
save the recombined Class file with a new name before you print reports.

Foreign Languages in Report Headers
You can add a foreign language to eClass Grades reports.

To do this, open a copy of eClass Grades with Apple�s ResEdit utility and edit 
STR# resources 128 through 132.
Using Advance Reporting Features
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ResEdit is available on Apple�s web site at: 
http://www.info.apple.com/support/downloads.html

ResEdit is a programmer�s tool used to manipulate Macintosh files on a very 
low level. You should not use it unless you are certain you know what you are 
doing, and you have a backup of the file.

If you have replaced text for one of the five languages with text from a 
different language, for example, replacing French with Italian, you should 
select the name of the original language in the General Report Prefs dialog 
from the Style menu. The name of the new language will not appear as an 
option.

Print a report, and you will see that your report headers have changed.

Foreign Languages in Reports
You can use eClass Grades to print Individual and Group Reports in English, 
Spanish, French, German, and Russian.

To use Russian, you need a special font. Look on your favorite font online 
service for a Cyrillic font that has a page set number of 1251. Install that font.

TO USE A DIFFERENT FONT FOR REPORTS:

1 From the Style menu, choose Font, and designate the new font to be used 
for each section of reports.

2 To choose the language, use General Report Prefs from the Style menu.

3 Then select the appropriate language from the Print Reports in popup 
menu and click OK.

You will not see the language change on eClass Grades�s screen. The change 
only shows when you print or preview an Individual or Group Report.

eClass Grades does not translate words and phrases that you have typed, such 
as Category names, Student IDs, Notes, Comments, and so on. They appear 
in reports just as they were entered.

The language feature only controls certain keywords and phrases on reports: 
the words and phrases that are not user-definable through dialogs. For 
example, in the table of scores on a Group Report, the Name column heading 
will change according to the language you have selected. But the Misc. 1 
column heading will not automatically change because it is controlled by your 
settings in the Student Data dialog from the Style menu.

So, if you would like your report to print entirely in a language other than 
English, you will need to change all appropriate text in the Class file to the 
language you want.

For example, use Comments from the Class menu to change comments.
Using Advance Reporting Features
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Use Grading Periods from the Class menu to change the descriptions of 
grading periods.

Use Individual Report Prefs from the Style menu to change Progress Report 
to the appropriate language, and so on.

Insert Special Language Characters
Sometimes, if you are printing in a language other than English, you�ll want to 
create comments, post scripts, or special scores that include special characters.

To enter a special character, go to another program that can produce such 
characters and copy the character. This places the character in your 
computer�s temporary clipboard.

Then go to eClass Grades�s Comments, Post Scripts, or Special Scores dialogs 
and paste the letter into the appropriate location.

Programs, such as Key Caps on the Macintosh or Character Map on 
Windows, shows you a list of the fonts and characters available on your 
computer and will allow you to copy one or more characters at a time into 
your computer�s clipboard.

It is also possible to enter special characters into eClass Grades by typing in 
the special character�s ASCII code.

Russian Text in Reports
When you are editing comments, grading period descriptions, category 
descriptions, and so on, you generally have no control over which font will 
appear onscreen.

The Russian language requires a special font known as a Cyrillic font.

Cyrillic fonts will not show up in the dialogs for editing comments, grading 
periods, and so on.

To get comments, grading period descriptions, and so on, to appear on 
reports in Russian, you must first type the text into a word processor using a 
Cyrillic font.

Then, copy the text and paste it into the appropriate eClass Grades dialog.

When you do this, the text will look like gibberish inside the dialog because it�s 
not shown in a Cyrillic font, but it will print in Russian.
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